Microsoft Excel

Världens mest sålda kalkylprogram

Excel

Excel är idag det mest sålda kalkylprogrammet på marknaden och används av både företag och privatpersoner. Du kan skapa allt ifrån enkla, användbara och överskådliga kalkyler till riktigt avancerade beräkningsmodeller. Med hjälp av formler och funktioner får du Excel att utföra alla typer av beräkningar och analyser. Utifrån värdena kan du sedan skapa både tabeller, listor och avancerade diagram.


excel Identifiera kombinationer av värden i en tabell

Ibland kan man ha en lång lista där man behöver kunna identifiera vissa kombinationer av värden. Det kan då kan det vara bra att skapa en ny kolumn i listan som markerar den kombination du söker efter med t.ex. en etta ”1” om villkoret är sant. Detta gör man enklast med en OM-formel och då det är flera fält vi vill testa så kan det även vara bra att använda oss av funktionerna OCH, ELLER samt ICKE.

Nedan har vi en 'Dynamisk tabell' (se blogginlägg) med 1 000 rader som består av tre fält Region, Färg och Storlek med följande värden:

Region: Nord, Väst, Öst, Syd

Färg: Gul, Röd, Blå

Storlek: Stor, Liten, Mellan

Att manuellt gå igenom samtliga 1 000 rader är väldigt tidskrävande och tråkigt så då är det bättre att lägga till en kolumn som identifierar just den kombinationen vi är ute efter. Detta gör vi med en OM-formel. Då det kan finnas många kombinationer så kan en vanlig 'Nästlad OM formel' (se blogginlägg) bli väldigt lång och vi kan då använda oss av de logiska funktioner OCH, ELLER samt ICKE

OCH: Testar om två eller flera villkor är sanna så returnerar den värdet SANT. Ifall ett av villkoren är falska så returnerar den alltid FALSKT. För att returnera SANT så behöver samtliga villkoren vara sanna.

ELLER: Eller testar ifall något av villkoren är SANT. Den returnerar endast FALSKT då samtliga villkoren är falska.

ICKE: Funktionen ICKE vänder på ett villkor från FALSKT till SANT eller vice versa från SANT till FALskt. Det kan var bra för att korta ner längden på en villkorsuppsättning.

Nedan följer fyra exempel på olika villkor som vi testar mot våran tabell:

Kombinationen: Syd, Blå, Mellan

                           =OM(

OCH([Region]="Syd";[Färg]="Blå";[Storlek]="Mellan");

1;

0

)

Kombinationen: Syd, Blå eller Syd, Röd

                           =OM(

ELLER(

OCH([Region]="Syd";[Färg]="Blå");

OCH([Region]="Syd";[Färg]="Röd")

);

1;

0

)

Kombinationen: Mellan och är antingen Syd, Blå eller Syd, Röd

                           =OM(

OCH([Storlek]="Mellan";

ELLER(

OCH([Region]="Syd";[Färg]="Blå");

OCH([Region]="Syd";[Färg]="Röd")));

1;

                                                0

)

Kombinationen: Alla storlekar utom Mellan och är antingen Syd, Blå eller Syd, Röd

                           =OM(

OCH(ICKE([Storlek]="Mellan");

ELLER(

OCH([Region]="Syd";[Färg]="Blå");

OCH([Region]="Syd";[Färg]="Röd")));

1;

0

)

Ladda ner bifogad fil så kan du sortera efter villkorskolumnerna så får du se att det stämmer.

excel Räkna ord i en cell i Excel

Ibland kan man vilja veta antalet ord i en cell i Excel. Det finns ingen speciell funktion för detta utan vi får istället använda en kombination av framförallt funktionerna 'textformler bryt ut delar av epostadress' (se blogginlägg) och 'Byt ut och Ersätt text i Excel' (se blogginlägg) .

I tabellen nedan har vi en kolumn med texter i kolumn A med en tom cell högst upp. För att räkna ut antalet ord i varje enskild cell så använder vi oss i kolumn B följande formel:

=OM(ÄRTOM(A2);0;LÄNGD(A2)-LÄNGD(BYT.UT(A2;" ";""))+1)




Först så måste vi skapa en 'Funktionen OM' (se blogginlägg) som kollar ifall det överhuvudtaget finns ord i cellen, ifall det inte finns det så måste den returnera en nolla ”0”. Vi använder en OM-formel där vi även använder oss av funktionen 'testa om en cell är tom med hjälp av formel' (se blogginlägg) . Vi bryter ner formeln nedan:

 

=OM(ÄRTOM(A2);                                                                            >Villkor om cellen är tom

0;                                                                              >Om SANT, returnerar ”0” som i ”noll ord”

LÄNGD(A2)-LÄNGD(BYT.UT(A2;" ";""))+1         >Om FALSKT, Formel som räknar ord.

)                         

 

Formeln som räknar ord använder sig först av funktionen LÄNGD som räknar ut antalet tecken i cellen inklusive mellanslag ” ”.

Därefter använder vi oss återigen funktionen LÄNGD, fast vi har manipulerat texten med funktionen BYT.UT som byter ut alla mellanslag, ” ”, och ersätter dem med tomma värden ””.

Vi subtraherar sedan dessa två stycken samt adderar en 1:a och får på det sättet fram antalet ord i cellen. 

excel Beräkna roten ur och upphöjt till

För att beräkna roten ur ett tal kan man enkelt använda sig av formeln ROT().

Exempel: ROT(4) = 2, eller ange en referens istället för en nia.

Vill man kvadrera ett tal så kan man använda sig av funktionen UPPHÖJT.TILL(). Den funktionen ber om två värden. Först vårat tal och sedan vår exponent.

Exempel: =UPPHÖJT.TILL(2;2) = 4, eller ange en referenser.

Ett annat sätt att göra en ”upphöjt till” beräkning är att använda sig av tecknet ”^”. Du får fram det tecknet genom att hålla inne Shift och tryck på en knapp som brukar ligga ovanför din högra Shiftknapp.

Exempel: 2^2 = 4, kan även använda referenser istället för tal.

ROT() funkntionen räknar endast ut kvadratroten. Vill man göra en kubrot, dvs tredje graden rot eller annan grad så blir ^-tecknet väldigt användbart. Detta eftersom om vi använder ett bråktal som exponent så får vi en rot-beräkning.

Exempel: 4^(1/2) = 2, dvs samma som ROT(4)

Exempel: 8^(1/3) = 2, det är kubroten dvs exponenten är 1/3.

Se även tabellen nedan för exempel och du kan ladda ner filen under rubriken ovan.



excel Namnge områden med Namnhanteraren

I Excel så refererar man ofta till ett område med värden. Istället för att manuellt mata in dessa via tangentbord eller musmarkering så kan man namnge och spara referenser. Det kan bland annat göra det enklare för oss när vi skapar formler.

VI skall göra ett enkelt exmepel på hur man kan jobba med formler genom att räkna ut värden från en tabell och välja element via en dropdownlista. Exempelfil kan laddas ned under rubriken.

Vår data består av en tabell med två kolumner Land och Försäljning enligt bilden nedan. Vi skall börja med att namnge värdena i respektive kolumn. Under Fliken Formler – klicka på Definiera namn så att du får upp dialogrutan enligt nedan.

Namn – Här namnger du området i vårat fall .

Refererar till – Här markerar du de celler som området skall referera till, B2 till B9.

Klicka sedan OK.

För att summera den totala försäljningen så kan man nu istället enkelt ange området Försäljning och det kommer automatiskt fram som förslag när du skriver in formeln.

    =SUMMA(Försäljning)

Motsvarar alltså:

    =SUMMA(B2:B9)

Gör samma sak fast för området A2 till A9 där vi har namnen på länderna. Man kan även under fliken Formler klicka på knappen Namnhanteraren. Då får du upp bilden nedan där du får en överblick över din områden. Du kan härifrån redigera dom och även skapa nya eller ta bort befintliga.

'Infoga Dropdown lista' (se blogginlägg) med ländernas namn genom att markera D2. Fliken Data – klicka på Dataverifiering så att du får upp dialogrutan Dataverifiering enligt nedan.

Ställ in enligt bilden ovan. Notera att vi nu inte anger cellreferenser som vår källa utan området Länder, som i sin tur innehåller cellreferenser. Klicka sedan OK.

Ställ upp som i bilden nedan med en 'funktionen summa.om' (se blogginlägg) funktion där villkoret pekar mot värdet i dropdownlistan.

Man kan nu enkelt göra sina beräkningar genom att välja från dropdownlistan och det är väldigt enkelt att se vad som raknas ut.


excel Funktionen TECKENKOD

Funktionen TECKENKOD ber om ett numeriskt värde 0-255 och returnerar dess motsvarande ASCII värde. Den här funktionen kan vara användbar om man tillexempel behöver ange ett icke utskrivbart tecken vilket de första 32 värdena representerar.

Du kan läsa mer om ASCII värden genom att klicka på följande länk: https://www.asciitabell.se/

Se även följande blogginlägg där vi måsta använda oss av TECKENKOD i en formel för att 'Radbrytning i en cell i Excel med formel' (se blogginlägg) .